We review vendors based on rigorous testing and research but also take into account your feedback and our affiliate commission with providers. Some providers are owned by our parent company.
Learn more
vpnMentor was established in 2014 as an independent site reviewing VPN services and covering privacy-related stories. Today, our team of hundreds of cybersecurity researchers, writers, and editors continues to help readers fight for their online freedom in partnership with Kape Technologies PLC, which also owns the following products: ExpressVPN, CyberGhost, and Private Internet Access which may be ranked and reviewed on this website. The reviews published on vpnMentor are believed to be accurate as of the date of each article, and written according to our strict reviewing standards that prioritize the independent, professional and honest examination of the reviewer, taking into account the technical capabilities and qualities of the product together with its commercial value for users. The rankings and reviews we publish may also take into consideration the common ownership mentioned above, and affiliate commissions we earn for purchases through links on our website. We do not review all VPN providers and information is believed to be accurate as of the date of each article.
Advertising Disclosure

vpnMentor was established in 2014 as an independent site reviewing VPN services and covering privacy-related stories. Today, our team of hundreds of cybersecurity researchers, writers, and editors continues to help readers fight for their online freedom in partnership with Kape Technologies PLC, which also owns the following products: ExpressVPN, CyberGhost, and Private Internet Access which may be ranked and reviewed on this website. The reviews published on vpnMentor are believed to be accurate as of the date of each article, and written according to our strict reviewing standards that prioritize the independent, professional and honest examination of the reviewer, taking into account the technical capabilities and qualities of the product together with its commercial value for users. The rankings and reviews we publish may also take into consideration the common ownership mentioned above, and affiliate commissions we earn for purchases through links on our website. We do not review all VPN providers and information is believed to be accurate as of the date of each article.

How to Set Up NordVPN on a Router in 2024: Easy Tutorial

Kennedy Otieno Updated on 4th December 2023 Cybersecurity Researcher

Setting up NordVPN on a router is more complex than it is on a phone or PC. Routers need manual configuration, while other devices simply require you to download and install the app. Still, you can do the router setup on your own in a few steps.

I’ve put together a comprehensive step-by-step guide on how to install NordVPN on different routers. I’ve covered the setup for ASUS, DD-WRT, and OpenWRT routers, but the process is more or less similar on other brands (if you have a Netgear router, just bear in mind that you’ll need to install DD-WRT firmware before you can configure NordVPN).

While it takes a little more effort to set up NordVPN on a router, it’s worth it. It means you can protect as many devices as you want — including those that aren’t usually compatible with VPNs — just by connecting them to your router. You also get access to the VPN’s huge server network for unblocking content on any device on your home network. Plus, trying out NordVPN is free because it has a 30-day money-back guarantee.

Get NordVPN for Your Router Now

Important note: Flashing your router can cause permanent damage (bricking) if not carried out correctly. If you need to install additional firmware to make your router compatible with NordVPN, always follow an in-depth guide or ask a professional to do it for you.

Quick Guide: How to Set Up NordVPN on a Router in 3 Easy Steps

  1. Download the VPN. If you don’t have a subscription yet, you can try NordVPN risk-free, thanks to the 30-day money-back guarantee. Get the NordVPN router app or configuration settings from the official website.
  2. Set up your router. Sign in to your router control panel and enter the server settings.
  3. Connect devices to your router. Test your connection via a service like ipleak.net. If your IP address is hidden, you can now use NordVPN to safely access the internet and unblock geo-restricted services from any device connected to your home network.

Which Routers Support NordVPN?

Brand Models
ASUS RT-AX86U, RT-AX88U (AX 6000, AC3100), RT AC-5300, RT-AC66U B1, RT-AC68U, RT-AC86U, RT-AC87U, RT-AC3200, RT-AX3000, RT-N18U, ASUS WRT Merlin
D-Link (needs flashing with DD-WRT) DIR-885L, DIR-895L
Linksys (needs flashing with DD-WRT) EA8500, WRT1900ACS, WRT3200ACM
Netgear (needs flashing with DD-WRT) R6400, R7500, R7800, R8500, R9000
Other Brands GL.iNet, MikroTik, Netduma, OPNsense, Padavan, Sabai, pfSense (OpenVPN only), DrayTek Vigor, EdgeRouter and Ubiquiti, TP-Link

NordVPN mainly works with routers that support the OpenVPN protocol. Several router models offer this feature, but most ISP routers don’t because they prefer the BGP protocol. Netgear routers also don’t have built-in OpenVPN. If your router doesn’t support OpenVPN, you can configure it with NordVPN by flashing your router with DD-WRT firmware first. Any router with Merlin, Tomato, and OpenWRT firmware can also be installed with NordVPN.

You can find out whether your router supports VPNs by logging in to your account and looking for VPN Settings (or something close to that) in the menu.

How to Set Up NordVPN on Your Router

The NordVPN setup process varies slightly depending on your router manufacturer or model. I’ve covered all the steps here but NordVPN also provides 24/7 live chat support if you need assistance at any stage.

Regardless of your router device, there are basic preparations to do before setting up. Have the following information ready:

Router IP address: This can be found at the back or bottom of your device. It should look something like this: 198.162.1.1.

Router credentials: The default username and password are sometimes shown next to the IP address information. You can use this if you haven't changed the login information before.

NordVPN subscription: Have your VPN sign-in information ready. If you don't have an account yet, you can use the 30-day money-back guarantee to try NordVPN for free.

Server and protocol configuration settings: Get the recommended OpenVPN settings for any server/location you want to connect to from the NordVPN server utility page.

1. How to Set up NordVPN on an ASUS Router

ASUS routers are preferred for NordVPN because of the built-in OpenVPN client. It makes the setup process seamless on any model. Here are the steps to follow:

  • Open a browser on your device and enter the router IP address on the URL bar (press the “Enter” key to access). It’s a good idea to bookmark the router config page for easy adjustment later.
  • Provide your router credentials on the prompt asking you to log in (your admin password can usually be found on a sticker on your router).
  • Scroll down and click the VPN section, then go to VPN Client and Add Profile.
  • Click OpenVPN and fill in the following required information:

Description: Give a name for your connection (NordVPN + [the name of your chosen server country] makes it easy to locate).

Username: Enter your NordVPN username.

Password: Enter your NordVPN password.

(Don't close this window yet. We're still going to import NordVPN OpenVPN configuration settings here.)

  • Open the NordVPN server utility page (mentioned in our preparations above) in a new tab.
  • Enable Auto-reconnection if you want the VPN to automatically restart in the event of a dropout.
  • Choose your preferred server location.
A screenshot of NordVPN server utility pageUse a recommended server or pick any location to set up your router
  • Copy the server information and click show protocols.
  • Download the OpenVPN config (TCP or UDP) files in a safe location.
A screenshot of NordVPN router protocolsOpenVPN is the right protocol for router setup
  • Return to the ASUS control panel page and click Choose file.
  • Find the file you downloaded (it has a.ovpn extension) and click
  • Upload the file.
  • Click OK to complete the configuration (don’t check the box next to Import the CA or edit the.ovpn file manually).
  • On the VPN Client window, click Activate to enable the NordVPN profile you’ve created (a blue tick on the left indicates your connection status). You can also deactivate the NordVPN connection here.

2. How to Set Up NordVPN on a DD-WRT Router

DD-WRT firmware supports the OpenVPN protocol, so you can set up NordVPN if you have a DD-WRT router. Here’s how:

  • Connect your laptop to the DD-WRT router via WiFi or LAN cable.
  • Enter your router IP in the browser address bar and log in to the control panel.
  • Go to Setup > Basic Setup, then Network Address Server Settings (DHCP).
  • Enter the following:

Static DNS 1: 103.86.96.100

Static DNS 2: 103.86.99.100

Static DNS 3: 0.0.0.0 (default)

UseDNSMasqforDHCP: (check the box)

UseDNSMasqforDNS: (check the box)

DHCPAuthoritative: (check the box)

  • Click Save, then Apply settings.

Before proceeding any further, let's disable IPv6 connections on the router (this prevents your real IP address from being leaked while using the VPN).

  • In the Setup section, click IPv6, then check the Disable
  • Save and Apply Settings

Next, we can configure the router's OpenVPN client with NordVPN settings.

  • On the Setup window, click Service > VPN.
  • Scroll down to OpenVPN Client and enable the Start OpenVPN Client

The other configuration settings are:

  • Server IP/Name: Enter the information you got from the NordVPN server configuration page. For example, mine is nordvpn.com
  • Port: 1194 or 443
  • Tunnel Device: TUN
  • Tunnel Protocol: UDP (or TCP)
  • Encryption Cipher: AES-256-CBC
  • Hash Algorithm: SHA-512
  • User Pass Authentication: Enable
  • Username, Password: Your NordVPN account info
  • First Data Cipher: Not set
  • Second Data Cipher: Not set
  • Third Data Cipher: Not set
  • User Pass Authentication: Enable
  • TLS Cipher: None
  • LZO Compression: None
  • NAT: Enable

In the Additional Config section, copy and paste this information:

remote-cert-tls server

remote-random

nobind

tun-mtu 1500

tun-mtu-extra 32

mssfix 1450

persist-key

persist-tun

ping-timer-rem

reneg-sec 0

#log /tmp/vpn.log

We are now going to use the config file you downloaded from the NordVPN utility server page (in the preparation stages).

  • Find the.ovpn file and open it with a text editor application like Wordpad or Notepad++.
  • Copy all the text enclosed in tags (highlighted in blue below).
A screenshot of data from NordVPN configuration fileThe “ca” tag section contains NordVPN root configuration data and must be accurately copied
  • Paste the data into the CA Cert box of the ASUS OpenVPN client section.
  • Return to the configuration file and copy the TLS Key content after the tag (highlighted below).
A screenshot of TLS Key data in the NordVPN config fileThe TLS data contain authentication keys used for encryption
  • Paste the information in the TLS Auth Key
  • Click Save and Apply Settings.

To check if the VPN is working (on the administrative panel), go to Status > OpenVPN > State. It should show Client: CONNECTED SUCCESS.

3. How to Set Up NordVPN on an OpenWRT Router

Alongside the OpenWRT firmware, your router should be installed with the OpenVPN client (I’ll show you how to do this in the guide).

With that said, the OpenWRT configuration goes like this:

  • Connect to the OpenWRT router WiFi on your PC or another device.
  • Access your router’s command line by entering the default LAN IP address 192.168.1.1 in your browser.
  • Enter root as the default password (if you’ve never changed the default settings) with the command passwd.
  • You’ll be logged into a remote SSH command line.
  • Install OpenVPN by entering (copy/pasting) the following command:

opkg update

opkg install openvpn-openssl

opkg install ip-full

  • We can make the OpenVPN protocol launch automatically each time the router starts by using this command:
/etc/init.d/openvpn enable
  • Next, find the server configuration file you downloaded from the NordVPN server utility (during the preparations). For example, mine is nordvpn.com
  • Go back to the SSH command line and copy/paste the following information. However, modify the section after /servers/ by entering the server address you stored. It should look something like this:
wget -P /etc/openvpn https://downloads.nordcdn.com/configs/files/ovpn_udp/servers/us6778.nordvpn.com.udp.ovpn

The above instruction will download the OpenVPN configuration file into the directory /etc/openvpn.

Often, OpenVPN configuration requires a password wherever you use the OpenVPN connection. We can change that.

  • First, use this command to install nano text editor:
opkg install nano
  • Next, we can open the downloaded configuration file using the nano text editor by entering the command:
nano /etc/openvpn/us6778.nordvpn.com.udp.ovpn
  • Look for the string auth-user-pass and append the word secret next to it. The string should look something like this:
auth-user-pass secret
  • Save all these changes by pressing CTRL+X, Y, and Enter.
  • We must also create a corresponding file named “secret” by running this command:
nano /etc/openvpn/secret
  • Nano text editor will automatically open this file. You should then enter your NordVPN login credentials — username in the first line and password in the second. Save this information by pressing CTRL+X, Y, and

Next, we can do the OpenVPN client configuration process.

  • Find the server configuration file you downloaded from the NordVPN server utility (during the preparations). Change its extension from .ovpn to .conf so OpenVPN can easily locate it.

Alternatively, you can use this mv command:

mv /etc/openvpn/us6778.nordvpn.com.udp.ovpn
/etc/openvpn/us6778.nordvpn.com.udp.conf
  • We can specify this file in /etc/config/openvpn Copy/paste this UCI command:

uci set openvpn.nordvpn=openvpn

uci set openvpn.nordvpn.enabled=’1′

uci set openvpn.nordvpn.config=’/etc/openvpn/us6778.nordvpn.com.udp.ovpn’

uci commit openvpn

Also append the below string command to the /etc/config/openvpn directory file:

config openvpn 'nordvpn'

option enabled '1'

option config '/etc/openvpn/us6778.nordvpn.com.udp.ovpn'

  • Let's also create a network interface. Copy-paste the following lines:

uci set network.nordvpntun=interface

uci set network.nordvpntun.proto='none'

uci set network.nordvpntun.ifname='tun0'

uci commit network

  • Append the following strings command to the /etc/config/network file:

config interface 'nordvpntun'

option proto 'none'

option ifname 'tun0'

  • We can then create a firewall zone to forward LAN traffic to the VPN. Use this command:
lan
  • Next, configure the router to use NordVPN DNS servers. Add them using this command:

uci set network.wan.peerdns='0'

uci del network.wan.dns

uci add_list network.wan.dns='103.86.96.100'

uci add_list network.wan.dns='103.86.99.100'

uci commit

  • In the file /etc/config/network, the following strings should be included in the Wan section:

config interface 'wan'

<...>

option peerdns '0'

list dns '103.86.96.100'

list dns '103.86.99.100'

  • Finally save these entries using CTRL+X, Y, and Enter.

Confirm if the setup is working by checking your protection status on the NordVPN homepage. You should see Protected on the top bar (before the menu bar).

FAQs on Setting Up NordVPN with a Router

Why should I install NordVPN on my router?

It encrypts your WiFi and protects all your connected devices from cyber threats. That means hackers can’t steal your data or read your communications from your home or office network. NordVPN’s AES 256-bit encryption and secure protocols scramble your traffic, providing security and privacy for browsing.

Installing NordVPN on your router also gives you unlimited connections and lets you use the service with devices that don’t usually support VPNs (like Apple TV, Nvidia Shield, and Xbox consoles). That way, you can make the most of NordVPN’s security and unblocking features on any device connected to your WiFi. Plus, the VPN can add a layer of privacy for IoT and smart home devices on your network, like security cameras and smart speakers.

Which routers aren’t compatible with NordVPN?

Any router that doesn’t support the OpenVPN protocol won’t work with NordVPN. The service no longer accepts L2TP/IPsec and PPTP connections, meaning you can't set it up on most ISP-issued routers (like a Virgin router). Still, there are a good number of router brands and firmware compatible with NordVPN that you can use.

Here are some of the routers you can’t set up with NordVPN (unless you flash them with custom firmware):

  • Arris
  • Belkin
  • Cisco
  • D-Link
  • Huawei
  • Netgear
  • TRENDnet
  • Tenda
  • Linksys (except WRT32X and WRT32XB AC3200)
  • TotoLink
  • Ubee

What should I do if NordVPN is not working with my router?

You can try flashing your router with custom firmware if it isn't compatible with NordVPN. Some of the supported firmware are Merlin, Tomato, and Padavan. That said, the process is complex and should only be done by an expert to avoid bricking your router. Alternatively, you can get a NordVPN-compatible router and do an easy manual configuration.

If you already have a NordVPN-compatible router but it’s still not working with the VPN, here are some other solutions you can try:

  • Check your internet connection — You may be experiencing a general outage, rather than a VPN issue. Check your connection with your ISP.
  • Check your hardware and software — Inspect your LAN cable for any loose connections. Install any important updates you're missing and restart the router to refresh the system. Always leave your router at least 2 minutes before switching it back on again.
  • Switch servers — You may have encountered a NordVPN server that’s down for maintenance or blacklisted (especially if you find you can’t unblock content with your router setup). Choose a different server configuration file during setup to switch to another VPN location.
  • Check for double coverage — If you enable NordVPN on your router and then enable it on your device, you’ll get double coverage. Routing your traffic through the VPN twice can cause connectivity issues and slowdowns, so always disable the app on any device connected to your router.

Does NordVPN support OpenVPN?

NordVPN only works on routers with the OpenVPN client. Other protocols like PPTP and L2TP/IPsec aren’t supported. It’s easy to set up NordVPN on any router with a built-in OpenVPN protocol, like ASUS.

Some mesh routers work with OpenVPN, but models that only have “pass-through” support won’t work. You can check if your router supports OpenVPN in its accompanying manual. If your router firmware doesn't support OpenVPN, you can download and install systems (like DD-WRT) that allow you to configure NordVPN manually.

Are there routers with NordVPN built in?

Yes, some flash routers are pre-configured or pre-installed with NordVPN. You don't have to do manual configuration after buying, just a few optimization settings. You don’t need one though, most routers have a simple setup process, so you can do almost everything on your own.

How can I use NordVPN on a Netgear Nighthawk router?

You can install NordVPN on a Netgear router using DD-WRT firmware. Most Netgear routers don’t have this firmware, requiring you to flash before setting up NordVPN. If that’s too technical, get a router that’s compatible with NordVPN instead. ASUS models are recommended because the built-in OpenVPN client makes the process easier.

Can I set up a free VPN on a router?

It’s not recommended. Most free VPNs aren’t reliable because of their weak security and usage restrictions. They can’t protect you from cyber threats such as hacking and usually aren’t strong or fast enough to unblock any content. Instead, configure your router with a low-cost premium VPN that’s safe and doesn’t limit your usage — like NordVPN. That way, you get a reliable, secure connection that doesn’t put your online privacy at risk.

Some free VPNs can also deliberately violate your privacy by collecting sensitive data, such as browser searches, and selling it to third parties for a profit. Worse, others hide malware or spyware in their downloads to steal your information.

Get NordVPN on Your Router Now

Configuring NordVPN on a majority of routers is a matter of just a few minutes. After you've adeptly set up the VPN on your router, every device linked to your WiFi will have protection from online threats.

NordVPN is great for router devices because of its robust encryption and fast speeds. It runs many global servers, allowing you to configure your router for unblocking geo-restricted services. Plus, there are reps on standby if you need any help with setting up. You can also try NordVPN for free, thanks to its 30-day money-back guarantee. If you find it’s not right for your router, just get a refund.

Privacy Alert!

Your data is exposed to the websites you visit!

Your IP Address:

Your Location:

Your Internet Provider:

The information above can be used to track you, target you for ads, and monitor what you do online.

VPNs can help you hide this information from websites so that you are protected at all times. We recommend ExpressVPN — the #1 VPN out of over 350 providers we've tested. It has military-grade encryption and privacy features that will ensure your digital security, plus — it's currently offering 49% off.

Visit ExpressVPN

We review vendors based on rigorous testing and research but also take into account your feedback and our affiliate commission with providers. Some providers are owned by our parent company.
Learn more
vpnMentor was established in 2014 as an independent site reviewing VPN services and covering privacy-related stories. Today, our team of hundreds of cybersecurity researchers, writers, and editors continues to help readers fight for their online freedom in partnership with Kape Technologies PLC, which also owns the following products: ExpressVPN, CyberGhost, and Private Internet Access which may be ranked and reviewed on this website. The reviews published on vpnMentor are believed to be accurate as of the date of each article, and written according to our strict reviewing standards that prioritize the independent, professional and honest examination of the reviewer, taking into account the technical capabilities and qualities of the product together with its commercial value for users. The rankings and reviews we publish may also take into consideration the common ownership mentioned above, and affiliate commissions we earn for purchases through links on our website. We do not review all VPN providers and information is believed to be accurate as of the date of each article.

About the Author

Kennedy is a Cybersecurity Researcher and Writer at vpnMentor. He tests VPN software to give legit user experiences that help people make informed choices. Kennedy also puts together detailed setup and troubleshooting guides for mobile, PC, and router devices.

Did you like this article? Rate it!
I hated it! I don't really like it It was ok Pretty good! Loved it!
out of 10 - Voted by users
Thank you for your feedback